Call for testing: Minetest Snap

I’ve put a snap of the latest Minetest in the store under snapcrafters. Minetest is “A free, open source voxel game engine and game. Fully extendable. You are in control.”

How to install

snap install minetest --candidate

How to run

Search for the familiar Minetest icon in your desktop launcher, or snap run minetest or /snap/bin/minetest.


Requested Setups

I’ve tested the game a few times on my 16.04 nVidia-equipped laptop, connected to remote servers and had some fun punching cows*.

I’m interested to know about how well it works on other setups, releases and distros. All feedback welcome :slight_smile:

Reporting Feedback

Please report any issues with the snap on this thread, here on the forum.

* No cows were harmed during this testing


Thanks a lot for snapping Minetest! I tried it on my machine with 17.10 (Intel integrated graphics) using the X11 session and it worked just fine. I created some offline worlds (haven’t tried multiplayer yet). It also uses less resources than Minecraft :slight_smile: I didn’t meet any cows though, so I couldn’t verify that ^^

1 Like

It loads and runs fine on my nvidia machine. I don’t really know what I’m doing, though, so can’t say my testing has been very thorough. Looks entertaining. Ta muchly.

1 Like

try punching a tree :wink:

1 Like

there were no trees on mine. I disappoint.

but there was a bug.


Can you provide more detail about what happened, how you triggered this error?

Hi! I’m trying to use Minetest Snap in server mode(Ubuntu Server 18.04LTS). I managed to change the default configuration by adding the minetest.conf file to snap / minetest / current. However I’m having problems to migrate players database backend from files to sqlite3, obtaining this output:

$ minetest --server --migrate-players sqlite3 --world snap/minetest/135/worlds/world
2018-07-16 15:22:31: WARNING[Main]: system-wide share not found at “/share/minetest”
2018-07-16 15:22:31: WARNING[Main]: system-wide share found at “/snap/minetest/135/bin/…/share/minetest”
2018-07-16 15:22:31: WARNING[Main]: Couldn’t find a locale directory!
2018-07-16 15:22:31: ERROR[Main]: Cannot read!

Any advice? Thanks!

1 Like