Call for testing: Mailspring

Hey folks! I’m the lead maintainer of the Mailspring email client (formerly Nylas Mail). Over the last few weeks we’ve been putting together a snap release and working through a few configuration and sandboxing issues (couldn’t make ourselves the default client anymore, etc.) Now that snapd 2.29.3 is out, the last known issue has been fixed!

If anyone has some spare cycles and is interested in trying a new mail client (or already using Mailspring!) grab the snap and give it a spin via snap install mailspring! If you run into any issues, please post them here. We’ll be directing folks to the snap release instead of the dep / rpm packages in the next update cycle providing everything goes well. I’m really excited to be moving to snapcraft because it means Linux folks are finally getting autoupdate alongside our Mac and Windows users.

Note that in order to use Mailspring you’ll need to create a “Mailspring ID”, but the app doesn’t send your email passwords or credentials to the cloud—all email sync is done locally on your computer. It just syncs snooze dates and other metadata using the Mailspring ID, since those features can’t be built on IMAP alone.


Works as well as the deb package with some difference. I think some fonts are not installed that’s why there’s a square in the subject of the welcome email from mailspring team:

I think I have found my new email client!

I notice the snap contains app.asar and app.asar.unpacked. Do they both need to be there? Can some space be saved by only shipping one variant?

Desktop notification does not work…

  • Run with Debug Flags creates all sorts of errors, is this meant to happen?
  • Create A Plugin…, Open JavaScript Logs, and Open Mailspring Logs don’t work (i.e. nothing happens when you click on those menu items)
  • Menu theming is broken (problem with snappy)

Trying to avoid getting involved here too much - very behind on uni work atm - but a snapped email client? I had to give this a go…

@d0od has listed many bugs on his article:

  • Doesn’t use system theme (as I said)
  • Slow to launch - I find this is true for all snaps, idk why, they just take longer to launch than traditionally-packaged apps. Not unbearably longer but noticeably. Ideally someone should measure this difference
  • Notifications don’t work (I think they did for me but maybe Thunderbird wasn’t closed properly or something)
  • The tray icon doesn’t appear without TopIcons Plus (problem with Ubuntu’s AppIndicator/KStatusNotifierItem support for GNOME Shell?)
  • No fancy unread count on the dock item (feature of Dash to Dock/Ubuntu Dock)

Hey folks! Thanks for the feedback - this is really helpful.

@popey - yep, both of those are required. The app.asar.unpacked directory contains files we can’t include in the .asar file because they need to be accessible to the external filesystem. The app.asar file essentially “links” out to them in the unpacked directory.

@atse47 - I’ll look into the desktop notifications. We’ll probably need to add a post-installation note about any libraries you need to have installed for them to work.

@Ads20000 / @d0od - I think the system theme is something they’re working on in snapd. (Would actually be curious to know what the plan is for that…) I’ve also noticed that the app is suuuper slow to launch, especially the first time it’s run. I think it must be doing some sort of on-the-fly unpacking or setup? I’ll look into that tray icon issue—we definitely need that resolved.

I think the fancy unread count on the dock icon is still a work-in-progress, though we should support the Unity dock badge. Will see what’s going on there as well.


Works for me. I am on Ubuntu 17.10 and just ran snap install.

Seems to work really well. The only issues that I have found so far are that the mouse pointer doesn’t scale on high DPI displays and the menu tabs don’t seem to use the theme.

I set up my Gmail account. I was correctly warned at the beginning that the All email box was not enabled in IMAP, so I enabled it and everything now looks fine.

I think this topic in particular is in need of some research. It’s notable that some desktop apps have a lengthy startup time. I suspect there some work needed in the desktop launchers which seem to do a bit of scurrying around before actually launching the app.

Perhaps we can loop @kenvandine to help us understand the bottlenecks here?

1 Like

I bet that the desktop part could setup a hook, maybe install, to do the compilation of schemas at installation time instead of first launch.

I am running KDE Neon. When testing the Mailspring snap I get the Password Management Error message. In the message dialog there was a reference to a support article that suggested to install the package libgnome-keyring-dev, but that didn’t help. I also tried to install libsecret, another support page mentioned that package, but with the same result.

Probably doesn’t help because such dependencies may need to be provided in the snap? Or there needs to be a way for the snap to use the traditional deps on the system? Idk.

Other issues with the snap:

  • When saving an attachment, the /run/user/1000/snap.mailspring folder is opened by default, really it should be ~/Downloads
  • Window > Zoom and Window > Message Viewer buttons do nothing

One thing I’ve noticed is that I don’t see a mail count for email in labels, is that just me or thought out that way?

I have the snap, and the deb installed side by side. The icon is different (maybe on purpose?). Circle vs square. But I like that as I know which I am launching.

I have not had some of the other issues people have described. (i.e. - slow launch, etc)

I’m not sure if it is helpful to echo “me too” on the same issues that others have reported (theming, etc.). But I can add them in if needed.

Things that I noticed that are different between the two:

  • on the deb, super+arrow (or dragging to screen edge to move a window to left/right does not work (gnome 3.26 - under budgie), but the snap it does work!
  • slightly different build numbers between deb/snap (deb 1.0.8-5a387d0e, snap 1.0.8-b72efe94) - but may either be not relevant, or explain the minor differences)
  • Some settings differences - but I attribute that to the variance in build number.

I’ll continue to test, but I’m sure my info thus far is just an echo of the others in here.

Tiling to half the screen doesn’t work for me with the snap.

Tiling to half the screen doesn’t work for me with the snap.

Which DT environment are you running?