Call for testing: leagueoflegends


#9

Valid points should not have posted call like that sorry for the inconvenience.

Updated first post with disclaimer.

feel free to Close or Lock this thread if necessary.

Thanks

TR


#10

Client works really well but after the pick time is ended and game starts it’s crashes and I get bugsplat error.


#11

Try the workaround posted in github issue.


#12

This did not work for me. I tried even downloading trough lutris but there even LoL client does start. Right now for Fedora you snap packages is best one.


#13

If you don’t have wine install on your system then you will need wine deps for fedora and for other distros and if you use Nvidia then install its i386 gl packages, I don’t know which packages fedora uses.

If above does not work for you then you have to setup Windows VM or Windows partition whichever you prefer to download and update game then transfer it to snap WINEPREFIX.


#14

Well, I had problems in Fedora, even with docker and postgresSQL and decided to distro hop to ubuntu and now everything is working. The game is a bit laggy on my old laptop but good fun.


#15

It’s worked for me with fewer problems than Windows for the last 6 months. Now with the update last week, when I open the launcher I get the message “We’re unable to log you in because you may be offline.”

Last month I got a popup alerting that Riot Games was ending support for Windows XP, which Wine is using, so that is probably related to the issue.


#16

my launcher freezes at the start point


#17

Recent game update broke client for many users, check the same issue posted by other users.


#18

Maybe wineprefix broken I had many reverts and updates to wine-platform snap could have caused issue, so try recreating fresh wineprefix also make sure you have backup you game folder then restore it after launching snap then close dialog where it asks for game region.


#19

LOL worked yesterday, won’t today. Title graphic won’t come up. I uninstalled and reinstalled snapd and leagueoflegends, and now it asks me to choose download location, acts like it downloads the game, and then disappears.


#20

If you have fresh install league snap edge then you have to install wine-platform snap from edge as well in order run why this because yesterday I’ve pushed a change which changes snap base from core16 to core18.


#21

I uninstalled league of legends, snapd, and wine.

then I used sudo apt autoremove for clean up

then I installed wine 4.0 stable, snapd, and leaguoflegends --edge --devmode

same problem. gets to game installer region, downloads, then disappears.


#22

if it downloaded the installer then you have to wait for it to load up. Post log of errors or something useful.

snap info leagueoflegends
snap info wine-platform

Currently fresh install of league is broken in snap at the moment so I’m investigating the issue. though temporary you can copy over install game from somewhere to $HOME/snap/leagueoflegends/common/.wine/drive_c.

@joshmojo Issue is resolved now with recent update of wine-platform snap.

snap refresh --edge wine-platform


#23

League works very well on my Ubuntu 18.04, I have been trying it out since October.
I had to reinstall it a couple of days ago, and now I got a warning from the installer that Riot will no longer be supporting LoL on XP or Vista as of May, so if this setup is using either OS as a wine emulator will it be updated accordingly? Or is there a way to make changes manually by us users?


#24

It entirely depends on wine so if wine developers release new version suppose that has a fix for that issue then I’ll release update for wine-platform snap having that new wine version with fix.

Users can manually change it via winecfg but the game crashes with different Win version other then XP as wine needs fix that issue.

leagueoflegends.winecfg


#25

I understand it now, thank you for the explanation and for the hardwork you are putting into this.
Let’s hope they give us a fix before the deadline.


#26

Hello, I have been using this snap for a while now. it has worked great. occasionally it stops working and i run a refresh snap refresh leagueoflegends --devmode that will usually get me going again. But after this most recent lol update I am not able to get it working. I am mostly posting this to leave this report.

I want to thank you for you work on this snap. Before this snap I was playing with all of the wine settings myself and spending hours on trying to get it working well enough to play. it seemed that every other update required me to play with settings again. The snap version has been the most stable I have seen it. I appreciate the magic you work for us behind the scenes


#27

Recent patch have broke the game completely on wine, best we can do is to wait for another game patch or wine bug fix to happen so currently I can’t do anything from the snap atm.

You can track posted issue
https://bugs.winehq.org/show_bug.cgi?id=47198

Thank you.


#28

You can get solution on bugs.winehq.org If you are fan of lol game and want to download good images, Check out this League of Legends png images.