Call for testing: ipfs


IPFS is a free distributed file system that has served for the past few months to test our end-to-end workflows, from writing the snapcraft.yaml to continuous delivery to the users. But it also has been an useful experiment for the new role of the Ubuntu community, now that the software will be delivered directly from upstream, with no maintainers and no launchpad in the middle. I wrote a little about this here:

The latest version of IPFS, v0.4.8, is now in the candidate channel. And it can use some testing, so when it’s moved to the stable channel and auto-updated on the machines of all the users, they get a polished and flawless experience.

Here’s how to test the release:

Install the stable version:

$ sudo snap install ipfs

Run the smoke tests.

Stop the daemon.

Refresh to the new version:

$ sudo snap refresh ipfs --candidate

Run the smoke tests again.

For newcomers, this is a nice way to start learning about snaps and snapcraft, and about IPFS and distributed systems.

To get high-quality snaps, just like with debs, we need help from the community to run tests, make translations, write docs, fix bugs. It’s just the packaging where things are so easy now that once the simple yaml file is done, it’s not likely that we will have to look at it a second time. We now have many snaps in the store that would be happy to get more hands. If you want to help, let me know.

1 Like

Hello Leo,
I have tested on Zesty and had no problems, everything went fine also after the upgrade to v0.4.8.

1 Like

Thanks @letozaf, and everybody else who helped testing. v0.4.8 is now in stable.

A new release candidate for IPFS is coming. v0.4.9-rc1 is in the candidate channel. As usual, get it with:

$ sudo snap refresh ipfs --candidate

Here’s a quick peek at the stats. We are getting like 10 testers per rc, which is great. Thanks a lot.

candidate has now been bumped to v0.4.9-rc2.

And v0.4.9 is now out in the stable channel. The updates to all the users are happening as I write :smiley:

Between rc1 and rc2 we got 20 testers. Thanks a lot to the people who helped with the unstable channels.

It’s release time!!!

IPFS v0.4.10rc1 is in the candidate channel. Please run the tests as usual, an let me know how it goes.

1 Like

Tested on Ubuntu 16.04.2 LTS (Xenial Xerus), test produced no errors and everything worked just fine.

1 Like

Thanks @abhishek.tripathi24!


I’ve finished one of the pending tasks to automate the delivery of IPFS. The smoke test is now being run by Travis before pushing the snap to the edge channel in the store.

I wrote a little about this:

So from now on, the calls for testing don’t need the manual execution of the smoke. Everybody contributing can just focus on trying to break the system doing exploratory. And if somebody wants to help automating more tests, that will be very appreciated. Let me know and I can help you getting started.

pura vida, and thanks to everybody who has helped. We recently reached 1000 unique installs :slight_smile:

ipfs mount still doesn’t work.