Call for testing: chromium 65.0.3325.146


Thanks for the feedback @daniel. I’m trying to get my hands on nvidia hardware to reproduce and investigate the issue. Is there any chance you can test with an older version of the driver and/or on 16.04 or 17.10 ? I wonder if this is a general regression, or if it affects only 18.04.


Can you play content that uses DRM?


See that thread.


@oSoMoN The Chromium snap works with Nvidia drivers on my install of 17.10. I’m able to launch, sign in, and visit web pages. (Driver version 384.111, card is a MX150).


Thanks @petevg, that’s very useful feedback. So it looks like that might be a 18.04-only issue.


This might be related to that recent change in bionic.


I just published a new revision in the candidate channel that addresses two issues:

  • bug #1741078 - the chromium snap is now able to set itself as the default browser on the host system
  • moved the cache directory to under $SNAP_USER_COMMON/ so that cache data is not copied around with each upgrade

Please test and report issues here. Thanks!


Not sure if this theming issue is specific to the chromium snap, but GTK windows spawned from chromium (like the Save or Print dialogs) have black corners as shown in the attached image. Screenshot from 2018-03-11 07-42-33

Call for testing: chromium 68.0.3440.75

No HW Acceleration for me,
Using Gt640 (Nvidia Driver)
Arch Linux


This appears to be specific to the chromium snap. Issue tracked by bug #1755119, thanks for pointing it out!


Was this working on previous versions of the snap (e.g. the one currently in the stable channel, 64.0.3282.167)?

Which version of the NVIDIA proprietary driver? Does it work with an older version of the driver? Are other snaps able to use hardware acceleration?


Tried Stable Channel still isn’t working…
I did report it before.

➜ ~ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 390.25 Wed Jan 24 20:02:43 PST 2018
GCC version: gcc version 7.3.0 (GCC)

➜ ~ snap version
snap 2.31.1-2
snapd 2.31.1-2
series 16
kernel 4.15.8-1-ARCH


Right, that was that post.

Would you mind filing a bug with all those details so we keep track of the issue separately from this call for testing? Given it’s not a regression in this new version, it shouldn’t block the promotion to the stable channel.


I just published a new revision to the candidate channel that fixes bug #1755463. This will require the password-manager-service plug to be manually connected for now, but I am going to request it to be auto-connected.


Sorry for late reply, what should i post there? how can i debug? i am new to bug report writing :stuck_out_tongue:


Details about your distro, desktop environment, version and channel of the snap (and whether previous versions were already affected or if it’s a regression), version and channel of the core snap too, the screenshot you posted also contain useful information (the output of chrome://gpu can be saved as an HTML page), and the version of the NVIDIA drivers you’re using.
Basically the information you already shared on that thread! If more information is needed we can continue the conversation on the bug report. Thanks!


chromium 65.0.3325.146 has been promoted to the stable channel. Thanks everyone for testing!


I hope this is the right place to describe my problem, as the chromium snap I run does not match the version listed in the thread title.
I have a Problem with the Chromium Snap in Version 65.0.3325.181.

My Setup:
Fedora Atomic Workstation 27.112

Output of snap --version
snap 2.31.1-2.fc27
snapd 2.31.1-2.fc27
series 16
fedora 27
kernel 4.15.15-300.fc27.x86_64

Installation of the Chromium Snap works fine beside the usual SELinux Alerts.

Starting the Snap with snap run chromium works also fine, beside the following message:
“ATTENTION: default value of option force_s3tc_enable overridden by environment.”

Closing and starting the snap works now as intended.

However after I login with my google account and close the snap, I am unable to start the snap again.

Messages after I use 2FA:

LaunchProcess: failed to execvp: xdg-desktop-menu
[12970:12970:0413/] Missing ID token on refresh token fetch response.
[12970:12970:0413/135707.375360:ERROR:CONSOLE(1)] “Uncaught ReferenceError: inline is not defined”, source: chrome://sync-confirmation/ (1)

The Authentication seems to work, as my bookmarks are synced.
When I now close chromium and try to start it again, it does not show any window.

I tried to reset chromium in case of an error with an extension or something else, but this does not help (only if I log out again).

The output of snap run chromium is the same as before.
The following processes are running, even so chromium is not showing up:

snap/chromium/274/usr/lib/chromium-browser/chromium-browser --no-default-browser-check --no-first-run
/snap/chromium/274/usr/lib/chromium-browser/chromium-browser --type=zygote (2 times)

/snap/chromium/274/usr/lib/chromium-browser/chromium-browser --type=gpu-process --field-trial-handle=6399375770318590026,17004892076805191968,131072 --gpu-preferences=KAAAAAAAAAAAAQAAAQAAAAAAAAAAAGAAAQAAAAAAAAAIAAAAAAAAAAgAAAAAAAAA --gpu-vendor-id=0x0000 --gpu-device-id=0x0000 --gpu-driver-vendor --gpu-driver-version --gpu-driver-date --service-request-channel-token=9064012BD4B587AACB9D815CF10915F5

/snap/chromium/274/usr/lib/chromium-browser/chromium-browser --type=-broker

I tried this for several times. The snaps works always fine, until I login with my google account.


I found the following warning using debugging:

[8021:8236:0413/] Password storage detected desktop environment: GNOME
[8021:8236:0413/] Could not load cannot open shared object file: No such file or directory

Later follows:
[8021:8021:0413/] Password storage detected desktop environment: GNOME
[8021:8021:0413/] Trying libsecret for password storage.
[8240:8240:0413/] Activated seccomp-bpf sandbox for process type: gpu-process.


Thanks for reporting the issue @jonubulin. I can reliably observe it if I log in to a google account.

I added libsecret-1-0 to the snap and the related message went away, but still no window showing.
I then issued the following command, and lo! the browser started.

snap connect chromium:password-manager-service

I have filed bug #1763829 to track the issue.