Call for testing: chromium 61.0.3163.100


#8

Found the font package from solus, and added to the snap here.
A build will kick off automatically shortly, and I will update the candidate channel once built.


#9

And done. Can you refresh your snap from the candidate channel and let me know if the font issue is still there?

snap refresh chromium --candidate


#10

Just a quick polish note here, the icon shown in GNOME Shell on Ubuntu 17.10 is generic, not the Chromium icon. :slight_smile:


#11

It doesn’t work on 17.10, Wayland session.


#12

Thanks for the work! Apologies for the delay, this is my work machine

andy@asuras ~/Projects $ sudo snap refresh chromium --candidate
snap “chromium” has no updates available


#13

Icon in the dock, or in the activities view (or both)? Can you share a screenshot?


#14

Can you share details about your hardware (graphics card) and software:

snap info core chromium


#15

The snap was probably refreshed automatically. Can you share the output of:

snap info chromium

And is the problem with the font fixed?


#16

It was updated, sorry busy at work and didn’t even try checking loading the app, my apologies.

The title fonts look fine, but rendering on the page is still off

None of this is a road stopper for me, just thought it’s things you may want to address. Let me know if you need more info.


#17

Thanks for the feedback. The font rendering problem on web content is most likely another missing font package, I’ll see if I can figure out which.


#18

@diplo can you please share the output of:

gsettings get org.gnome.desktop.interface document-font-name


#19

I like the alerts on Discourse :slightly_smiling_face:

andy@asuras ~ $ gsettings get org.gnome.desktop.interface document-font-name
’Sans 11’

I was googling to try and work that out myself


#20

What is the output of:

fc-match Sans


#21

andy@asuras ~ $ fc-match Sans
ClearSans-Regular.ttf: “Clear Sans” “Regular”

I’m only here for another 25mins today, don’t have access to the machine till Monday I’m afraid, but will check here over the weekend, just don’t have the machine to test on.


#22

Thanks. If that was the setting being used to determine the font for web content rendering, it should be found as it is in the snap. I’ll have to keep digging. Can you share a screenshot of that page as rendered by the chromium snap: chrome://settings/fonts ?


#23

Good timing, just about to shut the machine down. Hope that is helpful, as I’ve said… this isn’t an issue for me, but nice to see how things work, will try and build my own snap next week.


#24

name: core
summary: snapd runtime environment
publisher: canonical
contact: snappy-canonical-storeaccount@canonical.com
description: |
The core runtime environment for snapd
type: core
snap-id: 99T7MUlRhtI3U0QFgl5mXXESAiSwt776
tracking: stable
installed: 16-2.27.6 (2898) 85MB core
refreshed: 2017-09-07 19:09:21 +1000 AEST
channels:
stable: 16-2.27.6 (2898) 85MB -
candidate: 16-2.28.1 (3017) 87MB -
beta: 16-2.28.1 (3017) 87MB -
edge: 16-2.28.1+git392.0a4186a (3033) 87MB -

name: chromium
summary: Chromium web browser, open-source version of Chrome
publisher: canonical
contact: olivier.tilloy@canonical.com
description: |
An open-source browser project that aims to build a safer, faster, and more
stable way for all Internet users to experience the web.
snap-id: XKEcBqPM06H1Z7zGOdG5fbICuf8NWK5R
commands:

  • chromium
    tracking: candidate
    installed: 61.0.3163.100 (49) 242MB -
    refreshed: 2017-09-29 04:35:20 +1000 AEST
    channels:
    stable: 60.0.3112.101 (9) 244MB -
    candidate: 61.0.3163.100 (49) 242MB -
    beta: 62.0.3202.29 (46) 241MB -
    edge: ↑

Hardware: 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)

When I start chromium from the snap under a Wayland session I see a chromium process running but no window appears. There is no error message. It works normally under the Xorg session.


#26

I have been using it for the whole day and it looks ok, no problem encountered. The only thing is that if you open a PDF in Chromium and then decide to save it, you have to search for your home/folder directory as you are, by default, in the snap folder.


#27

Doesn’t work for me.
OS: Ubuntu GNOME 17.04

Steps to reproduce

  1. sudo snap install chromium --candidate
  2. chromium

Output:

Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

Visual Output:


#28

Thanks for all the good feedback everyone. I am aware that the snap is not working for everyone yet, there are issues to be investigated and addressed, however it does work for a number of people in various configurations, so it doesn’t make sense to hold it off any longer, especially since the stable version for upstream chromium is now at 62. I have therefore promoted the snap from candidate to stable, and a build of version 62.0.3202.62 is underway, which I hope will hit the candidate channel early next week (a separate call for testing will be issued then).
Keep up the testing and the feedback!