Backup Snap that in not available on Snapcraft anymore

Hi all!

I tried to solve this using Google/Bing but I could’t. Hope you can save me.

I have a Snap installed on my Ubuntu (teams) and today it is not available to install (just a teams-for-linux app but it is not the same).

How can I backup that and install it again after a format or on a new computer?

I tried snapshot export/import but it did not work (I think it just save the configutarion of snap apps and before importing I need to install (and I can’t install because it is not available anymore).

So, what can I do?

Thanks in advance. Marcellus.

Teams has been discontinued by Microsoft as an individual app. It is now a progressive web app. To access it, you can do use any browser, but in my experience, it works better with chromium based browsers like: Chrome, Brave, Chromium, Edge etc.

Yeah, I know about the webapp, thanks.

The discontinuation is exactly why I want to backup the snap app that I use today.

The webapp allows copy/paste block, the old app doesn’t. :joy:

The snap file lives in /var/lib/snapd/snaps … you can copy (do not use mv while the squashfs is mounted! Use cp) it somewhere to later install it with the --dangerous option again… though I assume Microsoft will eventually block its usage since they already removed it from the store…

Thanks, @ogra!

Thats exactly what I was looking for and it worked fine!