503 error from api[.]snapcraft[.]io/v2/snaps/refresh when updating core20

503 error from api[.]snapcraft[.]io/v2/snaps/refresh when updating core20

This failure is happening nondeterministically at the end of building my snap. Entire build finishes succesfully with no signs of error prior to this.

I build my snap with

snapcraft --use-lxd --enable-manifest

The error I receive (just as it’s wrapping up).

An error occurred when trying to execute 'snap install --channel stable core20' with 'LXD': returned exit code 1.

error: cannot install "core20": cannot query the store for updates: got
       unexpected HTTP status code 503 via POST to
       "https://api.snapcraft.io/v2/snaps/refresh"

I caught a debug shell on a failing build with:

snapcraft --use-lxd --enable-manifest --debug

I found no issues with lxd or its interfaces & verified stable public network connectivity.